TechTalkz.com Logo Ask the Experts!

Go Back   TechTalkz.com Technology & Computer Troubleshooting Forums > Operating Systems > Open Source & Linux

Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Open Source & Linux

 
Reply
Thread Tools Display Modes
Unread 03-04-2012, 05:22 PM   #1
Tachikoma
Thread Starter
 
habibjp's Avatar
 
Join Date: Dec 2009
Location: Leeds
Age: 23
Posts: 2,912
Thanks: 94
Thanked 431 Times in 375 Posts
Mood: Innocent
Blog Entries: 9
Rep Power: 2487 habibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Great

AMD ATi

Windows 10 Linux


Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Hi all

Well, at least this time I managed not to **** up Windows

Anyhow, I can't remember which order i installed the various distros of Linux in (my original intended order was OpenSUSE>Mint>Xubuntu-obvs. I can't have done it in that order or Xubuntu would show up in GRUB), but Win was there before all of 'em.

Each distro was installed "alongside" the existing OS(s).

So, I need to edit the GRUB config file, right? I had a lookie via Google but everything I found made my head spin. Or just reinstall GRUB??

Basically I need to make Xubuntu show up, and ideally make Win7 boot by default.

Any help much appreciated
H

Sponsored Links
__________________
FX 4170 @4.8 w/H110
Sabertooth 990FX
XMS3 8GB
840 EVO 250GB
XFX 7870
Corsair GS500
X-Fi
Logitech Z506
---------------------------------------------
I aim to misbehave.
habibjp is offline   Reply With Quote
Unread 03-04-2012, 09:10 PM   #2
Senior Member (500+)
 
Wolfie276's Avatar
 
Join Date: Nov 2007
Location: /etc/rc.d/
Posts: 648
Thanks: 18
Thanked 52 Times in 47 Posts
Blog Entries: 1
Rep Power: 171 Wolfie276 is on a distinguished road


Windows 7 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Can you post your GRUB config?
Wolfie276 is offline   Reply With Quote
Unread 03-04-2012, 10:52 PM   #3
Tachikoma
Thread Starter
 
habibjp's Avatar
 
Join Date: Dec 2009
Location: Leeds
Age: 23
Posts: 2,912
Thanks: 94
Thanked 431 Times in 375 Posts
Mood: Innocent
Blog Entries: 9
Rep Power: 2487 habibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Great

AMD ATi

Windows 10 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Hrmm maybe. I'll try and find it tomorrow.
__________________
FX 4170 @4.8 w/H110
Sabertooth 990FX
XMS3 8GB
840 EVO 250GB
XFX 7870
Corsair GS500
X-Fi
Logitech Z506
---------------------------------------------
I aim to misbehave.
habibjp is offline   Reply With Quote
Unread 04-04-2012, 05:21 AM   #4
Elite Member (1000+)
 
echo off's Avatar
 
Join Date: Mar 2010
Location: Folkestone, UK
Posts: 2,449
Thanks: 240
Thanked 432 Times in 378 Posts
Mood: Tired
Blog Entries: 10
Rep Power: 6347 echo off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguishedecho off is extemly Distinguished

Intel Nvidia

Windows 98 / Windows ME Windows NT / Windows 2000 Windows XP Windows Vista Windows 7 Linux Mac OS


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Quad booting, jeez!
echo off is offline   Reply With Quote
Unread 04-04-2012, 11:08 AM   #5
Tachikoma
Thread Starter
 
habibjp's Avatar
 
Join Date: Dec 2009
Location: Leeds
Age: 23
Posts: 2,912
Thanks: 94
Thanked 431 Times in 375 Posts
Mood: Innocent
Blog Entries: 9
Rep Power: 2487 habibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Great

AMD ATi

Windows 10 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Just for the hell of it.


Anyhow, I'm gonna post the GRUB config just as soon as i can be bothered to restart into Mint today.
__________________
FX 4170 @4.8 w/H110
Sabertooth 990FX
XMS3 8GB
840 EVO 250GB
XFX 7870
Corsair GS500
X-Fi
Logitech Z506
---------------------------------------------
I aim to misbehave.
habibjp is offline   Reply With Quote
Unread 04-04-2012, 01:07 PM   #6
Senior Member (500+)
 
Wolfie276's Avatar
 
Join Date: Nov 2007
Location: /etc/rc.d/
Posts: 648
Thanks: 18
Thanked 52 Times in 47 Posts
Blog Entries: 1
Rep Power: 171 Wolfie276 is on a distinguished road


Windows 7 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

How did your root issue go by the way?

(I hate root so much!!! thread)
__________________
Arch Linux
Wolfie276 is offline   Reply With Quote
Unread 04-04-2012, 01:36 PM   #7
Tachikoma
Thread Starter
 
habibjp's Avatar
 
Join Date: Dec 2009
Location: Leeds
Age: 23
Posts: 2,912
Thanks: 94
Thanked 431 Times in 375 Posts
Mood: Innocent
Blog Entries: 9
Rep Power: 2487 habibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Great

AMD ATi

Windows 10 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Oh i think i gave up on it. Guess ima have to deal with it to find my GRUB config too :/
__________________
FX 4170 @4.8 w/H110
Sabertooth 990FX
XMS3 8GB
840 EVO 250GB
XFX 7870
Corsair GS500
X-Fi
Logitech Z506
---------------------------------------------
I aim to misbehave.
habibjp is offline   Reply With Quote
Unread 04-04-2012, 05:25 PM   #8
Tachikoma
Thread Starter
 
habibjp's Avatar
 
Join Date: Dec 2009
Location: Leeds
Age: 23
Posts: 2,912
Thanks: 94
Thanked 431 Times in 375 Posts
Mood: Innocent
Blog Entries: 9
Rep Power: 2487 habibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Great

AMD ATi

Windows 10 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Here's the GRUB config file, as it happens Mint has a shortcut to / in the main menu. (Anything-but-Ubuntu-for-the-WIN!!! )
Attached Files
File Type: txt grubcfg.txt (5.5 KB, 2 views)
__________________
FX 4170 @4.8 w/H110
Sabertooth 990FX
XMS3 8GB
840 EVO 250GB
XFX 7870
Corsair GS500
X-Fi
Logitech Z506
---------------------------------------------
I aim to misbehave.
habibjp is offline   Reply With Quote
Unread 04-04-2012, 07:23 PM   #9
Senior Member (500+)
 
Wolfie276's Avatar
 
Join Date: Nov 2007
Location: /etc/rc.d/
Posts: 648
Thanks: 18
Thanked 52 Times in 47 Posts
Blog Entries: 1
Rep Power: 171 Wolfie276 is on a distinguished road


Windows 7 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

As I thought, there is no Xubuntu entry.

Code:
menuentry 'Xubuntu'' --class gnu-linux --class gnu --class os {
	insmod part_msdos
	insmod ext2
	set root='($HD,$PART)'
	search --no-floppy --fs-uuid --set=root $UUID
	linux	$PATH_TO_BOOT_IMAGE root=UUID=$UUID ro   quiet splash
	initrd	$PATH_TO_INITRD_IMAGE
}
Try something along these lines. I'm assuming you know which partition it is on, and I suggest using UUID. You can find the partition UUID's with the "blkid" command.
Wolfie276 is offline   Reply With Quote
Thanked Users:
habibjp (04-04-2012)
Unread 04-04-2012, 07:36 PM   #10
Tachikoma
Thread Starter
 
habibjp's Avatar
 
Join Date: Dec 2009
Location: Leeds
Age: 23
Posts: 2,912
Thanks: 94
Thanked 431 Times in 375 Posts
Mood: Innocent
Blog Entries: 9
Rep Power: 2487 habibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Greathabibjp is just Great

AMD ATi

Windows 10 Linux


Re: Quad-booting W7, OpenSUSE, Mint and Xubuntu-Xubuntu has disappeared!

Sponsored Links
Okidoke i'll give it a go tomorrow morning, thanks.

Sponsored Links
__________________
FX 4170 @4.8 w/H110
Sabertooth 990FX
XMS3 8GB
840 EVO 250GB
XFX 7870
Corsair GS500
X-Fi
Logitech Z506
---------------------------------------------
I aim to misbehave.
habibjp is offline   Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone using Xubuntu? Dzhokhar O'Kelly-Davis Linux & Opensource 24 14-11-2007 07:30 AM
Xubuntu upgrade...how?!#@ Ken Lopez Ubuntu Linux 6 27-10-2007 07:59 AM
Xubuntu upgrade...how?!#@ Ken Lopez Ubuntu Linux 1 25-10-2007 04:27 AM
Any Xubuntu folks around here? Dzhokhar O'Kelly-Davis Ubuntu Linux 14 03-09-2007 03:01 PM
Xubuntu 7.04 Marge Inovera Ubuntu Linux 13 29-08-2007 12:21 PM


< Home - Windows Help - MS Office Help - Hardware Support >


New To Site? Need Help?

All times are GMT. The time now is 10:23 AM.


vBulletin, Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright © 2005-2016, TechTalkz.com. All Rights Reserved - Privacy Policy
Valid XHTML 1.0 Transitional