TechTalkz.com Logo Ask the Experts!

Go Back   TechTalkz.com Technology & Computer Troubleshooting Forums > Tech World > TIPS 'n' TRICKS

Installing CAB / MSI on Windows Vista

TIPS 'n' TRICKS

 
Reply
Thread Tools Display Modes
Unread 26-11-2006, 05:24 AM   #1
Webmaster
Thread Starter
 
Strider's Avatar
 
Join Date: Nov 2005
Location: Interwebs
Posts: 4,997
Thanks: 624
Thanked 726 Times in 610 Posts
Mood: Cynical
Blog Entries: 6
Rep Power: 9009 Strider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly EminentStrider is extemly Eminent

Intel Nvidia

Windows XP Windows Server 2003 / Windows Server 2008 Windows 7 Windows 8 Linux


Cool Installing CAB / MSI on Windows Vista

Most of our installers are having trouble in Vista. Among the reasons, the fact that we normally install our content under "Program Files" is something that Vista doesn't like for security reasons.

To successfully install CAB on Windows Vista you must follow the following steps:
  • Right click Start Menu > Accessories > Command Prompt icon and select "Run as administrator" command.
  • Point to the place where the CAB .msi is placed and run it from there.
If you try to run CAB .msi without "Run as administrator" command the installation will fail.

You can't select "Run as administrator" command directly on CAB .msi file because this options is not available on Windows Installer Packages.

Same is valid on Enterprise Library and other content from Microsoft.

Tom Hollander has posted about this some time ago: http://blogs.msdn.com/tomholl/archiv...15/756747.aspx
Strider is offline   Reply With Quote
Unread 26-11-2006, 06:31 AM   #2
ƒ(ψ)=ΘΊΧφ
 
bakuryu's Avatar
 
Join Date: May 2006
Location: India
Age: 28
Posts: 6,621
Thanks: 19
Thanked 673 Times in 626 Posts
Rep Power: 2153 bakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant futurebakuryu has a brilliant future


Windows XP Windows Vista Windows 7


Send a message via Yahoo to bakuryu
I think this is the problem when UAC is enabled. I have disabled it, and now no programs require Run As Administrator to be enabled.

Also I think the /a switch runs the apps as administrators. Read it somewhere but I forgot.
__________________
Please don't click here
bakuryu is offline   Reply With Quote
Reply

Thread Tools
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help installing windows vista from ISO file Al Windows Vista All 21 29-08-2007 07:00 PM
I need help installing windows vista from ISO file Al Windows Vista All 3 27-08-2007 10:00 PM
im installing windows vista, but i have a problem Gerarjunior925 Windows Vista All 3 17-08-2007 03:54 PM
Installing II7 on Windows Vista Business muriel Windows Vista All 0 17-08-2007 10:51 AM
Installing Windows XP / previous versions of Windows after Windows Vista Strider TIPS 'n' TRICKS 4 07-02-2007 06:39 AM


< Home - Windows Help - MS Office Help - Hardware Support >


New To Site? Need Help?

All times are GMT. The time now is 06:43 AM.


vBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO
Copyright © 2005-2013, TechTalkz.com. All Rights Reserved - Privacy Policy
Valid XHTML 1.0 Transitional